注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

淡忘邻人

二十七,始发愤

 
 
 

日志

 
 
 
 

cannot change version of project facet Dynamic web module to 2.5  

2014-02-20 22:43:25|  分类: Eclipse |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |










cannot change version of project facet Dynamic web module to 2.5 - 淡忘凛人 - 淡忘邻人

 eclipse如何修改dynamic web module version cannot change version of project facet dynamic web module to 2.5



eclipse如何修改dynamic web module version

一、修改工程属性:

右键eclipse的工程,选择属性,再选择Project Facets里面中选择Dynamic Web Module ,将3.0修改为2.5,可能会提示如下信息:
Cannot change version of project facet Dynamic Web Module to 2.5

这样表示修改不了,然后采用第二种方法。

二、修改配置文件:
找到工程项目的硬盘目录,打开项目下的 .setting文件夹,如下图:

cannot change version of project facet Dynamic web module to 2.5 - 淡忘凛人 - 淡忘邻人

 

找到 .setting文件夹内的org.eclipse.wst.common.project.facet.core.xml文件,文件格式大致如下:

<?xml version="1.0" encoding="UTF-8"?>
<faceted-project>
<runtime name="Apache Tomcat v5.5"/>
<fixed facet="jst.web"/>
<fixed facet="jst.java"/>
<installed facet="jst.java" version="5.0"/>
<installed facet="jst.web" version="2.5"/>
<installed facet="wst.jsdt.web" version="1.0"/>
</faceted-project>

直接手动修改jst.web对应的version即可。最后重启tomcatX就可以正常使用了。


  评论这张
 
阅读(255)| 评论(0)
推荐 转载

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017